maintenance: remove fix-compatibility.js

(cherry picked from commit af20e8a6970ec7f08799389ac9ce897d1cc822e0)
pull/2/head
MengYX 1 year ago
parent 42ea3651f2
commit 60ea6239eb
No known key found for this signature in database
GPG Key ID: E63F9C7303E8F604

@ -43,9 +43,7 @@ jobs:
node-version: "14"
- name: Install Dependencies
run: |
npm ci
npm run fix-compatibility
run: npm ci
- name: Build
env:

@ -17,9 +17,7 @@ jobs:
node-version: "14"
- name: Install Dependencies
run: |
npm ci
npm run fix-compatibility
run: npm ci
- name: Build Legacy
env:

@ -14,7 +14,6 @@
"serve": "vue-cli-service serve",
"build": "vue-cli-service build",
"test": "jest",
"fix-compatibility": "node ./src/fix-compatibility.js",
"make-extension": "node ./make-extension.js"
},
"dependencies": {

@ -1,25 +0,0 @@
//TODO: Use other method to fix this
// !! Only Temporary Solution
// it seems like that @babel/plugin-proposal-object-rest-spread not working
// to fix up the compatibility for Edge 18 and some older Chromium
// now manually edit the dependency files
const fs = require('fs');
const filePath = "./node_modules/file-type/core.js";
const regReplace = /{\s*([a-zA-Z0-9:,\s]*),\s*\.\.\.([a-zA-Z0-9]*)\s*};/m;
if (fs.existsSync(filePath)) {
console.log("File Found!");
let data = fs.readFileSync(filePath).toString();
const regResult = regReplace.exec(data);
if (regResult != null) {
data = data.replace(regResult[0],
"Object.assign({ " + regResult[1] + " }, " + regResult[2] + ");"
);
fs.writeFileSync(filePath, data);
console.log("Object rest spread in file-type fixed!");
} else {
console.log("No fix needed.");
}
} else {
console.log("File Not Found!");
}
Loading…
Cancel
Save